Clientware Configuration

The following tables list proprietary databases and the additional software ("clientware") needed to complete each connection.

Windows (32 & 64 bit*)

PostgreSQL 8.1 and later PostgreSQL Access Library; "libpq.dll" (supplied).
MySQL 4.1 and later None required (embedded)
SQLite (format 3) None required (embedded)
Amazon SimpleDB None required (embedded)
OpenBase 11.x None required (embedded)
FrontBase 4.x and later None required (embedded)*
Oracle 8i and later Oracle Instant Client 11g 11.1.0.7 or later
(Oracle Client 9i 9.2.0.1 or later required)
DB2 UDB 7.1 and later
DB2 Express 9.0 and later
DB2 Run Time Client 7.2 (DB2 v8 max)
DB2 Express-C Client 9.0 (DB2 Express-C /v9)
Sybase ASE 12.5 and later
Sybase ASA 9.0 and later
Open Client 15.0 or later (Open Client 12.5 or later required)
Use of Open Client 12.5 with Studio 4 .3 requires a substitute DAM
ODBC->Sybase ASA 9 and later
SQL Anywhere ODBC Driver (supplied with ASA)
ODBC->SQL Server 7/ 2000
ODBC->SQL Server 2005
ODBC->SQL Server 2008
Microsoft SQLServer2000 Driver 2000
Microsoft SQL Server Native Client 2005
Microsoft SQL Server Native Client 10.0
ODBC->Microsoft Access Microsoft Access Driver 4.00 or later

Notes

  • Please note that the 64-bit edition of Omnis Studio requires 64-bit clientware and vice-versa. The 64-bit ODBC DAM requires the 64-bit ODBC Administrator and 64-bit ODBC drivers.
  • Where Multi-tier ODBC access is specified for other platforms, the ODBC drivers listed above are recommended to complete the appropriate connection.
  • The FrontBase DAM can be obtained from www.frontbase.com

 

Mac OSX (32-bit)

PostgreSQL 8.1 and later PostgreSQL Access Library; "libpq.dylib" (supplied).
MySQL 4.1 and later None required (embedded)
SQLite (format 3) None required (embedded)
Amazon SimpleDB None required (embedded)
OpenBase 11.x None required (embedded)
FrontBase 4.x and later None required (embedded)*
Oracle 8i and later Oracle10g Client 10.1.0.3 or later (i386) (Technote TNSQ0010 explains usage)
For Studio 4.3, a PPC only DAM is also available: Download DAM
DB2 N/A
Sybase ASE 12.5 and later Open Client 12.5.2  or later
Studio 4.3 requires a substitute DAM (PPC only).
ODBC->Sybase ASA 9 and later
SQL Anywhere "dbodbcX_r.bundle" driver, (e.g. "dbodbc11_r.bundle")
Studio 4.3/5.0 requires a subsitute ODBC DAM . (Technote TNSQ0016 explains usage)
ODBC->SQLServer 7 and later Omnis ODBC DataBridge (Studio 6.0 and later)
OpenLink SQL Server Express Driver v6.1 (Unicode)
OpenLink SQL Server Lite Driver v6.1 (Unicode)
Actual Technologies SQL Server Driver v2.8f or later
ODBC->Microsoft Access Omnis ODBC DataBridge (Studio 6.0 and later)
OpenLink 5.1 Generic Multi-tier ODBC Driver

Notes

  • The Openlink Generic Multi-tier ODBC Software can be obtained from www.openlinksw.com
  • Actual Technologies ODBC Drivers can be obtained from www.actualtech.com
  • To complete an ODBC connection using the ODBC Data Bridge, please refer to the relevant Windows configuration.
  • The FrontBase DAM can be obtained from www.frontbase.com

 

Linux (64-bit)

PostgreSQL 8.1 and later PostgreSQL Access Library; "libpq.so" (supplied).
MySQL 4.1 and later None required (embedded)
SQLite (format 3) None required (embedded)
Amazon SimpleDB None required (embedded)
OpenBase 11.x None required (embedded)
FrontBase 4.x and later None required (embedded)*
Oracle 8i and later Oracle11g Instant Client 11.1.0.6 or later
DB2 UDB 7.1 and later DB2 Run-Time Client v7.1 or later
Sybase ASE 12.5 and later Open Client 15.0 or later
Use of Open Client 12.5 with Studio 4.3 requires a substitute DAM
ODBC->SQL Server 7 and later Omnis ODBC DataBridge (Studio 6.0 and later)
FreeTDS ODBC Driver 0.82 (non-Unicode only)
Data Direct 5.0 SQLServer Wire Protocol Driver*
EasySoft ODBC-ODBC Bridge v1.4.0*

Notes

  • To complete an ODBC connection using the ODBC Data Bridge, please refer to the relevant Windows configuration.
  • Certified with unixODBC Driver Manager v2.2.11 (libodbc.so.1.0.0)
  • The FrontBase DAM can be obtained from www.frontbase.com